•  ·  Standard
ariznaf Discussions

You seem to be right, a friend that compiles from sources said me it worked for him and it seems to work in windows.

I have installed the library using apt and now it works, so it seems it was a missing dependency in the appimage.

Please if you correct it in the next version tell us in order to remove that library (by the way it seems to be quite a big bunch of related libraries).

  • 158

OK, so ctrl or right mouse button has to be clicked when you click the color picker buttom at the left.

I had understood you should use ctrl or right button during the selection of the pixels in the photo, while you drag the mouse as it is common in other programs.

You are right, if I use ctrl to click in the button there appears a square rectangle that can be redimensioned.

Wrong interpretation in my side, sorry, solved "problem".

  • 159

I have enabled it (as I showed in the other thread) but there is no such option after restart.

I am using the Ansel version downloaded as appimage (0.0.0+285)

  • 159

Thank yo but I have activated it several days ago and restarted Ansel many time, no map module there.

I am using the downloaded appimage 0.0.0+285 in linux mint vera.

This are the options in preferences


And this the Atelliers menu after restart


  • 158

Mask opacity affects at the intensity of the selection, if you use 0% everything is un selected and there is no yellow area, as everything is unselected.

You have the selection inverted it seems, and everything is yellos, selected so it seems your selection is not selecting anything.

I usuallly do not use the left menu for selections, just when I need to delete a figure or something.

Usually you create the selection in the right menu.

But you can create it in the left an select one of the figures created to be applied to a module, they are the same, at the left you see al figures created for any module and grouped for figures used in a module.

It seems a bit confuse, I know.

  • 160
Added a discussion

The color picker in the darkroom is supposed to provide the mean, min or max (depends on selection) of the area you select when you use ctrl+click or the secondary mouse button.

But when you do that, the mouse cursor does not change int gives you the circular target and seems to provide only the value under the pixel pixcket and there seems to be no way to select a rectangular area.

Tested wotj 0.0.0+285 and linux mint vera.

  • 172

You have to have changed something.

May be you changed the mode (exclusive, inclusive,) or the composing of masks (union, intersection...)

Or may be you have created a Ptah independent of the module and have not applied it to a module.

Paths and modules are independent, you can create a path and apply it to several modules.

If you create the path under the module mask (at the right) it is automatically applied to that module, and selects the interior.

Be sure there are selected figures in the module mask.

  • 176

I think culling and rating is being reworked in Ansel, there is another thread about.

  • 177

The profile of the camera depends on the light, the color of the iluminant.

The card should be used each time you change the illuminant.

The results would be different if you take it under a D65 light in controlled conditions, at the sun in a sunny day or in cloudy day or at sunset.

It may be even different under a sunny day in different months or at different places.

ISo setting may also affect color captured by the camera

So you should use it at the beginning of the session or even more if you change the light.

  • 225

I could finally get darktable 4.0.1 installed using flatpak, as there seems to be no apt source for that version that can be installed in current linux mint/ubuntu releas directly.

Compiling from source requires donwnloading and compiling sources for the old dependencies.

I am not fan of the flatpak way, but it fits situations like this where there are many dependencies or incompatibilities with current versions of libraries in your system.

You can install it using the flatpak command and pointing it to flathub repository.

Flathub does not guarantee storing all versions or the time it would store available ones.

You can list the available versions and the list of commits uploaded to flathub using this command:


flatpak remote-info --log flathub org.darktable.Darktable


The commit for the 4.0.1 version (2022-9-18) Is: ffe32b5c29648562b2c400c4bf3df2832ca165a216ea6292e5a741f7e353955b

It seems you cannot install directly the commit you want (install subcommad does not admit commit option), but yo can install the last version and then downgrade to the commit you want using:


sudo flatpak install org.darktable.Darktable

sudo flatpak update --commit=ffe32b5c29648562b2c400c4bf3df2832ca165a216ea6292e5a741f7e353955b org.darktable.Darktable


After that you have version 4.0.1 of darktable installed in your system as al flatpak package.

  • 236
Added a comment to Flathub

I agree that flathub is like killing flies with cannons.

May be a good solution when the base OS and environment is too different from the environment that is needed by the target program, and it is a complex program with many dependencies.

For example to run an obsolete program that does not run on a modern environment and it depens on many deprecated libraries.

But for general use it generates too much overburden.

Appimage seems a better way, more light and still seems to provide isolation and distribution of needed dependencies.

The only draw back is that it does not provide an installation or updating process nor integration with the graphics environment (for example links in the application menu) that has to be made by hand, but not a difficult task.

  • 156

Print module never worked in windows.

There was no print module in the windows version of darktable in any versions.

The reason (if I remember it well) is that it uses cups and it is not available in windows, windows and linux manage printing quite differently.

What surprises me is that maps seems to work in windows but it is not available in linux.

  • 140
... or jump to: