Welcome to the community

The best social media network for people to connect, collaborate, share content and inspire each other.

I suspect that this is WAI

  • 23
changed a profile picture
  • 29
Added a discussion

In Lightable I cannot see the ratings of the images.

Running AppImage on Ubuntu. Problem persists even if I load older versions. No errors, except

Gtk-Message: 00:10:37.124: Failed to load module "appmenu-gtk-module"
Gtk-Message: 00:10:37.203: Failed to load module "canberra-gtk-module"
Gtk-Message: 00:10:37.205: Failed to load module "canberra-gtk-module"
Gtk-Message: 23:47:17.431: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
Gtk-Message: 23:47:17.433: Failed to load module "appmenu-gtk-module"

(firefox:475839): Gtk-WARNING **: 23:47:17.573: GTK+ module /snap/firefox/3131/gnome-platform/usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so cannot be loaded.

GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
  • 44
  • +1; I'm experiencing the exact same problem using AppImage on Ubuntu
  • problem persists even if I go back 3 versions
  • I see no errors in the command line
  • 44
Added a discussion

Windows 10 - Ansel ( ansel-eb70788-win64.exe )

Bonjour à tous,

Suddenly the bottom panel disappeared into the light table. But it is still present in the form of a very thin edging (1mm) at the foot of Ansel's window in the same gray as the left and right panels. And I can't find any way to enlarge it...

I tried to pass all values bottom_visible to TRUE in the anselrc file, but without success. I also deleted this file then relaunched Ansel without further success.

Furthermore, I also noticed that in the darkroom I no longer have access to the button allowing you to clone an image.

Last info, without being entirely certain, this seems to have happened after installing the ansel-eb70788-win64.exe version. I then reverted to ansel-26acfc2-win64.exe. But still no change.

Thank you for any help you can give me.

  • 64
Added a discussion

The first issue seems to be related to the problem mentioned elsewhere that the mouse pointer is not aligned with the area that is being clicked.

The second issue has been present for a while, but I keep re-compiling Ansel in the hope of things being fixed. It used to be the case that the selected preset in "Color balance rgb" was indicated by a checkmark and probably was highlighted as well, and this is no longer the case. This applies to pre-defined presets as well as presets defined by me. For other presets I've defined, e.g. in the Export module, this still works.

Compiled under Gentoo Linux 6.1.53 with gcc 13.2.1

  • 104

I'm refering to the itens not checked as visible on the display metadata preferences. The issues are not related, but I ended up listing them together, sorry about that.

Re-reading this post I saw that it is a bit confusing, it's my "self taught english" fault and a bit of laziness!!

  • 112

I've tried that but no go... btw, I found a way to solve my issue, found the relative size of the tab on a line on the file /home/~user/.config/ansel/anselrc

plugins/lighttable/metadata_view/windowheight=250 (the value that worked for me)

But thanks for the reply!

  • 113

merci Dom,

je parlais des différents mode de la table lumineuse....

Je voudrais aussi activer la surimpression des étoiles et couleurs, je ne trouve pas.

Merci pour les retours

  • 268

Double clic dans la table lumineuse pour basculer vers la chambre noire

Double clic dans la chambre noire pour revenir dans la table lumineuse

ou menu Ateliers, puis chambre noire ou table lumineuse

Je suis sous Linux

  • 283

Thank you for your answer, it's a shame about the export because I was used to exporting it directly when I was reworking a picture, it's easier for me

  • 295

Hey bigbasou,

the creation of duplicates has been moved to the Edit menu on top. There you can choose to Create new development (Ctrl + N) to start a duplicate with a reset history or to Duplicate existing development (Ctrl + D) to create a duplicate with the current history applied.

It is also true that a lot of shortcuts have been affected with the changes that Ansel has undergone. The export for example has been removed from darkroom all together so the shortcut only works in lighttable.

  • 295

The dropdown issue is already known: https://community.ansel.photos/view-discussion/clicking-issue-windows-10

What do you mean by the "hidden options" of the "display metadata" module? How is it related to the dropdown issue?

  • 322

Hey Nirceu,

  • you can ctrl+scroll while hovering "Display Metadata" to resize it. It's not very intuitive, but other modules resize the same way. Also you can configure which entries should be shown by clicking on the hamburger menu of the module.
  • 323
Added a discussion

the duplicate manager does not work in the darkroom as well as many shortcuts like export (CTRL+E)

  • 341
Added a discussion

bonsoir à tous,

je suis nouveau sur Ansel que j'essaie d'évaluer. Je viens de Darktable, qui effectivement devient une "usine à gaz".

Pour l'heure j'essaie de configure Ansel, et je me perds, la documentation ne correspondant pas à ce que je vois sur le logiciel.

Je travaille sous windows.

par exemple, comment choisit on le mode de la table lumineuse?

le raccourci W, décrit dans la donc n'existe pas dans l'appli....

Y a-t-il une doc à jour?

Merci des retour, et à bientôt

Michel Fiocchi

  • 391


If anybody is interested, there is a workaround for this bug which is not related to Ansel but to Gnome display and Wayland. You can download a Gnome extension solving this issue here: https://extensions.gnome.org/extension/1873/disable-unredirect-fullscreen-windows/

Best regards,


  • 356
Added a discussion

have to click slightly above the desired option to enable it on dropdown lists, on all modules.

hidden options for the "display metadata" module do not keep between sessions.

(KDE plasma 5.27.6 on old vaio SVD13215PXB)

  • 384
Added a discussion

Hi there, first, Ansel is great, much faster and pleasant to use on older systems than DT. But there are some things that really hold me adopting Ansel as my "go to raw processing app":

  • I totally understand the focus on the pipeline, but when a search for a module, the pipeline tab rolls to the left and get lost on that tab bar. I think that pipeline tab should be fixed on the left corner. It will save some time, mouse wheel rolls and clicks; (and yes, i read the article about removing the old iconic tab, but... i'm used to customize interface options on software that allows changes to suit my needs, and had my "favorites" tab well balanced...)
  • is there any way to resize the "Display Metadata" tab? for me, when enabled, it covers a fixed 3/4 of the left panel, and i cannot figure out how to resize it from the gui (i use the metadata to compare files in different folders, and enabling/disabling that module every time to change the active folder is annoying);
  • i can't find a way to configure the default set of modules enabled for "new" raw files. Every first time a raw file is opened, Ansel enables: 1.original, 2.raw black/white point, 3.demosaic... yada yada... 12.orientation. I can't figure out how to change the order, neither the items on this default list. Is it possible btw? Creating a new set of default modules or change the stack order will speedup my workflow;

And, one more time: congratulations for Aurélien (and others here who can code) for this initiative, you guys rock!

I really don´t know if my complaints are pathetic or important in any way, but they are coming from an inexperienced user, trying to leave adobe lightroom (for the average user, LR can do magic!).

hugs from Brasil and sorry about my english mistakes (self taught)!

  • 387
Added a discussion


I 'm really liking this fork of darktable but some things that are missing are preventing me from using it.I 'm in general very experienced in editing but i must say i 'm totally new to ansel and darktable. One thing that came up right after i switch from darktable to ansel is the highlight recontruction. The segmentation based highlight reconstruction in darktable produces far better results than what i could achieve in ansel which does not have that many options in the highlight module and filmic cannot achieve what the highlight module does in darktable. So i 'm not sure if it is possible to achieve same results as darktable with some other way or this feature is just missing for some other reason.

  • 794

Hello Alexis, this problem is already in the bugtracker, see the following link for more details and a possible workaround until we have a fix. https://github.com/aurelienpierreeng/ansel/issues/206

  • 805
Added a discussion


One of the issue i found with Ansel is i cannot easily click the choices of the drop down menus.For example to change filmick from v6 to v7 in order to pick v7 i have to do several clicks in order to manage to change the version (a lot of times i gave up) . This applies to all of the drop down menus

  • 845

It looks like you are experiencing the same problem as described here: https://github.com/aurelienpierreeng/ansel/issues/50

The report is quite old and it states that the work on that issue is on hold but maybe you can make something of Auréliens last comment.

About the "Metadata" display, I think it's normal that it is not included in the container. You can however configure what it shows with the hamburger menu and "ctrl+scroll" to change it's height.

  • 1036

Quelques remarques supplémentaires :


Le curseur "Allonger le temps de traitement" pourrait éventuellement être décalé plus bas dans les paramètres. A discuter. (Pour rappel, "Allonger le temps de traitement" va réduire les vitesses d'ordre 1, 2 3 et 4 et augmenter en proportion le nb d'itérations, pour conserver une "Force" globale équivalente). Le but est d'augmenter le temps de calcul pour un effet plus propre.


Calcul de radius et radius_center (correctif)

Je me suis rendu compte d'une erreur dans mes calculs de radius et radius_center : ceux-ci doivent être entiers !

Si par exemple l'utilisateur choisit d'influer les détails de 1px à 2px (radius_min = 1 px, radius_max = 2 px),on se retrouve avec :

  • radius_center = (2 + 1)/2 = 1.5[
  • radius = (2 - 1)/2 = 0.5

Ce qui ne marche pas !

La valeur critique qui doit être respectée, c'est le radius_min (car plus petit, et si l'utilisateur sélectionne 1px, il veut 1px, pas 0px ou 2px !). On peut tolérer une marge d'erreur sur le radius_max (c'est bien moins grave, et l'erreur est proportionnellement inférieure à celle de radius_min.

Il faut donc plutôt utiliser les formules suivantes :

Si radius_min = 0, alors :

  • radius_center = 0
  • radius = radius_max

Si radius_min > 0, alors :

  • radius_center = arrondi.sup( (radius_max + radius_min)/2 )
  • radius = arrondi.sup( (radius_max – radius_min)/2 )
  • où l'on comprendra que arrondi.sup est l'arrondi à la valeur supérieure.

Exemple : l'utilisateur choisit d'influer sur les détails de 3 à 8 pixels.

radius_center = arrondi.sup( (8+3)/2) = arrondi.sup( 5.5 ) = 6

radius = arrondi.sup( (8-3)/2 ) = arrondi.sup( 2.5 ) = 3

Le module diffusion et netteté influera donc en réalité sur les détails de 3 à 9 pixels.

En gros, on autorise (selon les valeurs choisies) une majoration de 1px sur le radius_max. ça ne devrait pas fondamentalement changer le résultat (de toute façon, il est impossible de sélectionner exactement de 3 à 8 pixels en mode avancé).

  • 1056
... or jump to: