Comment to 'Where is the maps module?'
  • Thank yo but I have activated it several days ago and restarted Ansel many time, no map module there.

    I am using the downloaded appimage 0.0.0+285 in linux mint vera.

    This are the options in preferences


    And this the Atelliers menu after restart


    • Ok so that would suggest that some map library dependency is not properly embedded into the AppImage. You will need to install it on your system for the time being.

      My money is on the package libosmgpsmap-1.0-dev. Can you try to install it or something similar (check for "OSM GPS MAP", with or without spaces, in your package manager) ? It doesn't have to be the version 1.0 exactly.

      • You seem to be right, a friend that compiles from sources said me it worked for him and it seems to work in windows.

        I have installed the library using apt and now it works, so it seems it was a missing dependency in the appimage.

        Please if you correct it in the next version tell us in order to remove that library (by the way it seems to be quite a big bunch of related libraries).

        • What is and is not embedded in the AppImage is defered to an automatic script to follow dependencies, issues with partial Lensfun embedding have already been reported, so OSM will be part of the same task of manually boundling missing libs.